Accueil > Références > Radio France Direct

Étude de cas Radio France Direct

Description
Retrouvez rapidement l’accès au direct de toutes nos radios : France Inter, France Info, France Culture, France Bleu et ses 43 stations locales, Fip, France Musique, Le Mouv.
Features
audio
la balise audio de html5 n'est pas supportée sur Android 2.1 et 2.2, jembe override la balise pour permettre d'écouter les flux live et aod sur ces appareils.
Notez aussi qu'à la compilation, jeMbe vous propose de définir l'audio en background. Le son que l'utilisateur écoute ne se coupera pas s'il sort de l'app consulter une autre application.
Mode avion
hors connexion, l'application ne doit pas être une coquille vide. Une gestion efficace de la détection de connexion permet d'informer l'utilisateur de l'état de son réseau sans donner à penser que l'application ait planté.
Player audio
Nous avons voulu un player universel qui lise les flux live, timeshifting et aod. Il fonctionne sur les app Android, iOS, WP mais aussi sur n'importe quel navigateur Internet.
Mise à jour
L'application appelle des json à chaque démarrage pour savoir quels flux appeler et quelles informations afficher. Les appels http au serveur sont réalisés avec l'API jeMbe. Voir la documentation.
Notifications
Lorsque l'on arrive sur l'app une notification apparait dans la barre des tâches. Vous pouvez gérer 3 types de notification : push, bulle sur l'icone, et info sur la barre de tache.
Accessibilité handicapé
Tous les éléments sont enrichit d'un attribut title permettent d'informer les malvoyants via la fonctionnalité voice over
Airplay
Si des enceintes airplay sont détectées, un icone vous propose de continuer l'écoute sur vos enceintes, télévision etc.
Audimat
L'application respecte les normes en vigueur de la mesure de l'audience.
Screenshots
Radio France Direct
Support
Cette application a été développée pour smartphone et tablette.
Téléchargement

Détails
Catégorie : Musique
Mise à jour : 22 octobre 2012
Version : 2.0.1
Taille : 4.8Mo
Éditeur : Radio France
Configuration requise : Nécessite iOS 4.0 ou une version ultérieure. Compatible avec Android 2.1 et plus récent.
Compatible iPhone 5 / iOS 6.
Développez vos applications mobiles et vos logiciels avec jeMbe®
 
Plan du site | Logiciel jeMbe® édité par boceto;